登录

linux安装php memcache扩展

Linux
0 990

安装依赖和memcached客户端

0001

12yum install libmemcached libmemcached-develyum install zlib zlib-devel

如果没有libmemcached将会出现以下错误:

checking for libmemcached location… configure: error: memcached support requires libmemcached. Use –with-libmemcached-dir=<DIR> to specify the prefix where libmemcached headers and library are located

ERROR: `/var/tmp/memcached/configure –with-libmemcached-dir=no' failed

如果没有zlib模块则会出现:

checking for the location of zlib… configure: error: memcache support requires ZLIB. Use –with-zlib-dir=<DIR> to specify prefix where ZLIB include and library are located

ERROR: `/var/tmp/memcache/configure –enable-memcache-session=No' failed

安装扩展

下载地址:https://github.com/php-memcached-dev/php-memcached/releases

12345wget https://github.com/php-memcached-dev/php-memcached/releases  cd php-memcached-3.1.3/ phpize ./configure --with-php-config=/www/server/php/72/bin/php-config //php-config路径根据安装的php目录  不同而不同本人是宝塔make && make instal

0002

安装成功之后进入php.ini中在最底部增加:

1extension=memcached.so

通过php --ri 查看memcache安装情况以及版本

0003

123456789101112[[email protected] php-memcached-3.1.3]# php --ri memcached memcached memcached support => enabledVersion => 3.1.3libmemcached version => 1.0.16SASL support => yesSession support => yesigbinary support => nojson support => nomsgpack support => no

如果是php-fpm需要重启php-fpm才能生效

发表评论

0 个回复

1xBet

1xBet

242 2017-05-15 加入 天津

(有时候读书是一种巧妙地避开思考的方法)

热门推荐

友情连接